Информатика, вопрос задал maria23476 , 1 год назад

❗Помогите пожалуйста написать программы❗
1 уровень- задача, которая умножает числа.
2 уровень- задача, которая находит целую часть и остаток от числа при делении.
Всё это надо сделать в PascalABC❗​

Ответы на вопрос

Ответил Quverqu
1

1 уровень❗

var

 a, b, product: integer;

begin

 writeln('Введите первое число: ');

 readln(a);

 

 writeln('Введите второе число: ');

 readln(b);

 

 product := a * b;

 

 writeln('Произведение двух чисел: ', product);

end.

Данная программа считывает два целых числа a и b с помощью функции readln, затем вычисляет их произведение и сохраняет результат в переменную product. Наконец, программа выводит на экран сообщение, содержащее произведение двух чисел, с помощью функции writeln.

2 уровень❗

var

 a, b, quotient, remainder: integer;

begin

 writeln('Введите первое число: ');

 readln(a);

 

 writeln('Введите второе число: ');

 readln(b);

 

 quotient := a div b;

 remainder := a mod b;

 

 writeln('Целая часть от деления: ', quotient);

 writeln('Остаток от деления: ', remainder);

end.

Данная программа находит целую часть и остаток от числа при делении. Входные данные запрашиваются у пользователя с помощью функции readln, затем выполняются операции целочисленного деления (div) и остатка от деления (mod). Результат выводится на экран с помощью функции writeln.

Новые вопросы