Помогите пожалуйста!
Написать программу вычисления функции y=f(x).Заполнить таблицу значений x, y=f(x) при x∈[a, b] с шагом h
Приложения:

Ответы на вопрос
Ответил angryfukse
0
#include <iostream>
#include <cmath>
using namespace std;
int main ()
{
float e=exp(1.0);
const double PI =3.141592653589793238463;
double x, y=0;
double a = -2*PI;
int b = 0;
cout << "Enter value for x: ";
cin >> x;
if (x < a)
{
cout << "Error! Invalid value X!";
}
if (x > b)
{
cout << "Error! Invalid value X!";
}
if (x <= -PI)
{
y = log(cos(5*x)-2*x)+1;
cout <<"y = " << y <<endl;
}
if (x > -PI)
{
y = 0,35*tan(0.1*x)-2*pow(e,-0.1*x);
cout << "y = " << y <<endl;
}
return 0;
}
Новые вопросы