Информатика, вопрос задал Алик6400 , 2 года назад

Помогите пожалуйста!
написать программу вычисления значения функции икс равно двенадцати а квадрат плюс семь а минус шестнадцать

Ответы на вопрос

Ответил estengseant
2
var a,x: Integer;
begin
writeln('Введите значение числа a');
readln(a);
x:=12*(a*a)+7*a-16;
writeln('Ответ: x=',x);
end.
Ответил Аноним
1
Значение полиномов эффективно вычислять не "в лоб", а с использованием схемы Горнера.
x = 12a² + 7a - 16 = -16 + a(7 + 12a)

PascalABC.NET 3.3.5, сборка 1640 от 17.03.2018
Внимание! Если программа не работает, обновите версию!

begin
  var a:=ReadReal('a=');
  var x:=-16+a*(7+12*a);
  Writeln('x=',x)
end.

Пример
a= 5.18
x=342.2488
Новые вопросы