Информатика, вопрос задал grabovasofia139 , 1 год назад

Помогите, пожалуйста. Написать программу в С.
Сформулируйте динамічний одновимірний масив, у якому 15 елементів, заповніть його випадковими числами та виведіть на друк. Оформіть генерацію і виведення масиву за допомогою функції користувача. Реалізуйте цю програму за допомогою операцій new та delete. ​

Ответы на вопрос

Ответил podaleksandr051
0

1. Створіть функцію для генерації масиву випадкових чисел.

2. Створіть функцію для виведення масиву на екран.

3. Створіть функцію main, яка буде викликати функції для генерації та виведення масиву.

4. Використовуйте оператор new для створення динамічного масиву.

5. Використовуйте оператор delete для звільнення пам'яті, виділеної для масиву.

Ось приблизний код для генерації масиву випадкових чисел:

c++

#include <iostream>

#include <cstdlib>

#include <ctime>

using namespace std;

void generateArray(int *arr, int size) {

srand(time(NULL)); // ініціалізуємо генератор випадкових чисел

for (int i = 0; i < size; i++) {

arr[i] = rand() % 100; // генеруємо числа в діапазоні 0-99

}

}

void printArray(int *arr, int size) {

for (int i = 0; i < size; i++) {

cout << arr[i] << " ";

}

cout << endl;

}

int main() {

int size = 15;

int *arr = new int[size]; // створюємо динамічний масив

generateArray(arr, size); // заповнюємо масив випадковими числами

printArray(arr, size); // виводимо масив на екран

delete[] arr; // звільняємо пам'ять, виділену для масиву

return 0;

}

Новые вопросы