ПОМОГИТЕ пожалуйста! Написать программу в Паскале. Найти все трехзначные числа, которые можно представить разностью между квадратом числа, образованного первыми двумя цифрами и квадратом третьей цифры. Очень нужно!
Ответы на вопрос
Ответил petyaGavrikov
0
Вот программа:
var n,i:integer;
begin
for i:=100 to 999 do
if i=(i div 10)*(i div 10)-(i mod 10)*(i mod 10) then writeln(i);
end.
А чисел таких оказалось всего 2:
100
147
var n,i:integer;
begin
for i:=100 to 999 do
if i=(i div 10)*(i div 10)-(i mod 10)*(i mod 10) then writeln(i);
end.
А чисел таких оказалось всего 2:
100
147
Ответил fancy888
0
Спасибо огромное.
Новые вопросы
Английский язык,
2 года назад
Математика,
2 года назад
Химия,
9 лет назад
Биология,
9 лет назад
Биология,
9 лет назад