помогите пожалуйста написать программу в паскале "дано целое число N (>0). Найти наибольшее целое число К, квадрат которого не превосходит N : K^2 <= N. функцию извлечения квадратного корня не использовать. " (используя оператор while) ребята, ВЫРУЧАЙТЕ!!!!
Ответы на вопрос
Ответил nemolkl
4
var N,k:integer;
begin
writeln('введите N');
readln(N); K:=n div 2;
while k*k>N do
k:=k-1;
writeln(k);
end.
{Возможны и другие варианты}
begin
writeln('введите N');
readln(N); K:=n div 2;
while k*k>N do
k:=k-1;
writeln(k);
end.
{Возможны и другие варианты}
Новые вопросы