Помогите, пожалуйста, написать программу в Паскаль, с помощью функции.
дан вектор n (1<=n<=100).Найти минимальный элемент, который не превышает целое число m.
Ответы на вопрос
Ответил Аноним
0
// PascalABC.NET 3.0, сборка 1088
const
nn=100;
type
Vector=array[1..nn] of integer;
function Min(a:Vector; n:integer):integer;
var
i,m:integer;
begin
m:=a[1];
for i:=2 to n do
if a[i]<m then m:=a[i];
Min:=m
end;
var
V:Vector;
i,n,m,mn:integer;
begin
Write('Количество элементов вектора: '); Read(n);
Write('Значение m: '); Read(m);
Randomize;
Writeln('*** Сгенерированный вектор ***');
for i:=1 to n do begin
V[i]:=Random(101)-50;
Write(V[i],' ')
end;
Writeln;
mn:=Min(V,n);
if mn<=m then Writeln('Минимум ',mn,' не превышает ',m)
else Writeln('Минимум ',mn,' превышает ',m)
end.
Тестовое решение:
Количество элементов вектора: 20
Значение m: -42
*** Сгенерированный вектор ***
-12 10 -47 8 6 -22 -4 8 -50 -2 36 -38 -39 -41 11 -46 41 -22 -50 24
Минимум -50 не превышает -42
const
nn=100;
type
Vector=array[1..nn] of integer;
function Min(a:Vector; n:integer):integer;
var
i,m:integer;
begin
m:=a[1];
for i:=2 to n do
if a[i]<m then m:=a[i];
Min:=m
end;
var
V:Vector;
i,n,m,mn:integer;
begin
Write('Количество элементов вектора: '); Read(n);
Write('Значение m: '); Read(m);
Randomize;
Writeln('*** Сгенерированный вектор ***');
for i:=1 to n do begin
V[i]:=Random(101)-50;
Write(V[i],' ')
end;
Writeln;
mn:=Min(V,n);
if mn<=m then Writeln('Минимум ',mn,' не превышает ',m)
else Writeln('Минимум ',mn,' превышает ',m)
end.
Тестовое решение:
Количество элементов вектора: 20
Значение m: -42
*** Сгенерированный вектор ***
-12 10 -47 8 6 -22 -4 8 -50 -2 36 -38 -39 -41 11 -46 41 -22 -50 24
Минимум -50 не превышает -42
Новые вопросы
Математика,
2 года назад
Биология,
2 года назад
Математика,
9 лет назад
География,
9 лет назад
Обществознание,
9 лет назад