Помогите, пожалуйста, написать программу в Pascal.
Напишите функцию выбора меньшего из целых чисел. Используйте ее в программе выбора наименьшего из трех чисел.
Ответы на вопрос
Ответил petyaGavrikov
0
var a,b,c,m:integer;
function min(x,y:integer):integer;
begin
if x<y then min:=x else min:=y;
end;
begin
write('a='); readln(a);
write('b='); readln(b);
write('c='); readln(c);
m:=min(min(a,b),c);
writeln('min=',m);
end.
Пример:
a=5
b=3
c=8
min=3
function min(x,y:integer):integer;
begin
if x<y then min:=x else min:=y;
end;
begin
write('a='); readln(a);
write('b='); readln(b);
write('c='); readln(c);
m:=min(min(a,b),c);
writeln('min=',m);
end.
Пример:
a=5
b=3
c=8
min=3
Новые вопросы
Английский язык,
2 года назад
Геометрия,
2 года назад
Геометрия,
9 лет назад
Математика,
9 лет назад