Помогите пожалуйста написать программу.
В одномерном массиве, состоящем из n вещественных элементах. Вычислить произведение положительных элементов массива.
Ответы на вопрос
Ответил 65biso2
0
C# 8.0:
var Arr = new double[]{-2,-1,1,2,3}; double Mult=1;
foreach(int i in Arr) if(i>0) Mult*=i;
Console.WriteLine(Mult);
Ответил KnowsUser1
0
Ответ:
PascalABC.NET
begin
ArrRandom(ReadInteger('Укажите длину массива: '), -2147483640, 2147483640)
.Where(x -> x > 0)
.Aggregate(BigInteger.One, (x, y) -> x * y).Println;
end.
Ответил boguor
0
Вдвоем - сила
Новые вопросы