помогите пожалуйста!!
написать программу в которой: вводится и выводится массив из 10 рандомных чисел (от - 10 до 10). Нужно найти сумму элементов массива и максимальное значение. Вывести ответы на экран.(через паскаль)
Ответы на вопрос
Ответил valgrisa
2
Ответ:
program test;
var i,s,m:integer;
a:array [1..10] of integer;
begin
randomize;
s:=0;
for i:=1 to 10 do
begin
a[i]:=random(21)-10;
write(a[i],' ');
s:=s+a[i];
if i=1 then m:=a[i]
else if a[i]>m then m:=a[i]
end;
writeln;
writeln(s);
writeln(m)
end.
Ответил vimmortal2
1
Программа:
Pascal:
var arr: array[1..10] of integer;
begin
for var i := 1 to 10 do arr[i] := random(-10, 10);
writeln('Массив: ', arr);
writeln('Сумма элементов массива: ', arr.sum);
writeln('Максимальный элемент массива: ', arr.max);
end.
Новые вопросы