Помогите пожалуйста написать программу в C++
Напишите класс, который принимает с клавиатуры целое число и проверяет, на какое количество двузначных чисел оно
делится. Результат проверки класс должен вывести на экран вместе с соответствующим текстовым сообщением
Ответы на вопрос
Ответил nazikmuz
1
Відповідь:
С++ code:
#include <iostream>
class Number{
private:
int num;
public:
Number();
Number(int);
Number(const Number&);
~Number() = default;
int exp();
};
Number::Number(){
num = 0;
}
Number::Number(int num){
this->num = num;
}
Number::Number(const Number& object){
this->num = object.num;
}
Number::exp(){
int counter = 0;
for(int i = 10; i < 100; i++){
if(this->num % i == 0){
std::cout << "Number: " << i << std::endl;
counter++;
}
}
return counter;
}
int main(){
int num;
std::cout << "Enter a number: ";
std::cin >> num;
Number numb(num);
int result = numb.exp();
std::cout << "Result: " << result << std::endl;
return 0;
}
Новые вопросы