Информатика, вопрос задал irjika , 9 лет назад

Помогите, пожалуйста, написать программу сравнения двух строк. Программа должна читать строки из файла и сравнивать нечетные и четные строки, которые следуют друг за другом.

Ответы на вопрос

Ответил Аноним
0
var
  f:text;
  s1,s2:string;
begin
  Assign(f,'file.txt');
  Reset(f);
  while not eof(f) do
    begin
    Readln(s1);
    if not eof(f) then
      begin
      Readln(s2);
      if s1<>s2 then
        begin
        Writeln(s1);
        Writeln(s2);
        Writeln
        end
      end
    end;
  Close(f)
end.
Ответил Troyansky
0
и в нем же присутствуют типичные ошибки (пропущенные ; и т.п.).
Ответил Аноним
0
С чего это Вы взяли, что все это нужно делать? В задании ничего подобного не сказано. что до "типичных ошибок" - это безответственное заявление с Вашей стороны. В реале за подобную наглую писанину я обычно бью по лицу, так что Вам повезло.
Новые вопросы