помогите пожалуйста написать программу си++
задан массив целых чисел вычислить сумму отрицательных элементов этого массива и определить их количество
Ответы на вопрос
Ответил qwert07
0
#include <iostream>
using namespace std;
int main()
{
int n, sum,howmuch;
sum = howmuch = 0;
cout << "Введите количество элементов массива" << endl;
cin >> n;
int a[n];
for(int i =0; i < n; i++){
cout << "Заполните массив" << endl;
cin >> a[i];
}
for(int i = 0; i < n; i++){
if (a[i] < 0)
{
howmuch++;
sum += a[i];
}
}
cout << "Сумма отрицательных элементов массива:" << sum << endl;
cout <<"Количество отрицательных объектов массива" << howmuch << endl;
return 0;
}
using namespace std;
int main()
{
int n, sum,howmuch;
sum = howmuch = 0;
cout << "Введите количество элементов массива" << endl;
cin >> n;
int a[n];
for(int i =0; i < n; i++){
cout << "Заполните массив" << endl;
cin >> a[i];
}
for(int i = 0; i < n; i++){
if (a[i] < 0)
{
howmuch++;
sum += a[i];
}
}
cout << "Сумма отрицательных элементов массива:" << sum << endl;
cout <<"Количество отрицательных объектов массива" << howmuch << endl;
return 0;
}
Новые вопросы
Литература,
2 года назад
Математика,
2 года назад
Литература,
9 лет назад
География,
9 лет назад
Литература,
9 лет назад