ПОМОГИТЕ ПОЖАЛУЙСТА написать программу проверки правильности вводимого пароля 1) с использованием if ; 2) с использованием while ; 3) с использованием repeat ...until ПОЖАЛУЙСТА , УМОЛЯЮ ВАС ПОМОГИТЕ
Ответы на вопрос
Ответил minioks
0
А-правильный набор цифр, b-набор цифр, подлежащих проверке.
Если Паскаль: writeln ("введите пароль"); readln;(b) if a=b writeln ("пароль правильный") else writeln ("пароль неправильный"); end
Если Паскаль: writeln ("введите пароль"); readln;(b) if a=b writeln ("пароль правильный") else writeln ("пароль неправильный"); end
Ответил Alphaeus
0
Program Ksushaa1999PasswordRepeat;
uses crt;
var
vvod,ok:string;
const
pass='[email protected]&$45%$!#hftHUgruG';
begin
writeln('*** Alphaeus is thinking... ***');
writeln('*** OK ***');
writeln();
repeat
writeln('Введите пароль ');
readln (vvod);
until vvod=pass;
writeln('Принято');
end.
Program Ksushaa1999PasswordWhile;
uses crt;
var
vvod,ok:string;
const
pass='[email protected]&$45%$!#hftHUgruG';
begin
writeln('*** Alphaeus is thinking... ***');
writeln('*** OK ***');
writeln();
while vvod<>pass do
begin
writeln('Введите пароль ');
readln (vvod);
end;
writeln('Принято');
end.
Program PKsushaa1999PasswordIf;
uses crt;
var
vvod,ok:string;
const
pass='[email protected]&$45%$!#hftHUgruG';
label
metka;
begin
writeln('*** Alphaeus is thinking... ***');
writeln('*** OK ***');
writeln();
metka: writeln('Введите пароль ');
readln (vvod);
if vvod<>pass then goto metka;
writeln('Принято');
end.
Новые вопросы
Литература,
2 года назад
Информатика,
2 года назад
Химия,
10 лет назад
Химия,
10 лет назад
Математика,
10 лет назад