Информатика, вопрос задал Morfine , 10 лет назад

Помогите,пожалуйста, написать программу по теме "Ветвление в алгоритмах" для Pascal.

Задача: определить существует ли треугольник со сторонами ABC и, если существует, то какой он (равнобедренный, равносторонний, произвольный). 

Заранее большое спасибо! 

Ответы на вопрос

Ответил mrproper89
0

(*Pascal ABC.Net*)
program triangle;
var a,b,c: integer;
begin
write('Введите стороны:'); readln(a,b,c);
if (a=b) and (a=c) then
write('Треугольник равносторонний')
else if (a=b) or (b=c) or (a=c) then write('Треугольник равнобедренный')
else write('Треугольник произвольный');
end.

Новые вопросы