помогите пожалуйста написать программу по инфе..."Напишите программу получение из заданного целочисленного массива размером 30 элементов кол-во положительных, отрицательных и нулевых значений "
Ответы на вопрос
Ответил Alphaeus
0
Program Adelia17;
uses crt;
const n=30;
var
matr:array [1..n] of integer;
i,pos,neg,zero:integer;
begin
writeln('*** Alphaeus is thinking... ***');
writeln('*** OK ***');
writeln(); writeln();
writeln('Программа находит количество положительных, отрицательных и нулевых элементов массива');
pos:=0; neg:=0; zero:=0;
randomize;
writeln('Массив: ');
for i:=1 to n do
begin
matr[i]:=random(100)-50;
write(matr[i]:4,' ');
if matr[i]>0 then pos:=pos+1;
if matr[i]<0 then neg:=neg+1;
if matr[i]=0 then zero:=zero+1;
end;
writeln();
writeln('Количество положительных элементов равно ',pos);
writeln('Количество отрицательных элементов равно ',neg);
writeln('Количество нулевых элементов равно ',zero);
end.
uses crt;
const n=30;
var
matr:array [1..n] of integer;
i,pos,neg,zero:integer;
begin
writeln('*** Alphaeus is thinking... ***');
writeln('*** OK ***');
writeln(); writeln();
writeln('Программа находит количество положительных, отрицательных и нулевых элементов массива');
pos:=0; neg:=0; zero:=0;
randomize;
writeln('Массив: ');
for i:=1 to n do
begin
matr[i]:=random(100)-50;
write(matr[i]:4,' ');
if matr[i]>0 then pos:=pos+1;
if matr[i]<0 then neg:=neg+1;
if matr[i]=0 then zero:=zero+1;
end;
writeln();
writeln('Количество положительных элементов равно ',pos);
writeln('Количество отрицательных элементов равно ',neg);
writeln('Количество нулевых элементов равно ',zero);
end.
Новые вопросы
Русский язык,
2 года назад
Русский язык,
2 года назад
Математика,
9 лет назад
Литература,
10 лет назад
Обществознание,
10 лет назад