Информатика, вопрос задал duolypa , 2 года назад

Помогите пожалуйста написать программу. Нужно чтобы человек вводил фрукт, а программа выводила ему белки, жиры и углеводы фрукта. Дам много баллов!!!


duolypa: Язык программирования С++

Ответы на вопрос

Ответил maxpavlutenkof
1

#include <iostream>

#include <array>

#include <map>

// структура данных такова

// 1. открываешь фигурные скобки

// 2. название фрукта в двойных ковычках

// 3. открываешь фигурнуые скобки

// 4. 3 числа - жиры, белки, углеводы

// по этому шаблону запиши фрукты и их хар-ки сам (с русским языком могут быть проблемы)

std::map<std::string, std::array<float, 3>> bd = {

{"apple", {1.0, 1.0, 1.0}},

{"banana", {2.0, 2.0, 2.0}},

};

using std::cout, std::cin;

int main()

{

std::string fruit;

cout << "enter fruit: ";

cin >> fruit;

if (bd.find(fruit) != bd.end())

{

cout << "\tfats:\t\t" << bd[fruit][0] <<

"\n\tproteinsand:\t" << bd[fruit][1] <<

"\n\tcoals:\t\t" << bd[fruit][2] << std::endl;

}

else cout << "unknown fruit";

}


duolypa: спасибо большое
Новые вопросы