Информатика, вопрос задал ksusu1 , 2 года назад

Помогите пожалуйста написать программу!
Найти сумму чётных чисел в интервале от А до В ( А и В - натуральные числа, А< В).


Аноним: ДА уж....два решения - и оба с алгоритмом, за какой я студентам в свое время безапелляционно ставил "неуды". Ну зачем, когда просят пройти по четным числам, идти по всем подряд и проверять каждое на чет/нечет? Неужели сложно найти первое четное и пройти интервал с шагом два без всяких проверок?
Аноним: Поневоле вспомнился Я.Гашек: "...Скажи-ка лучше, как бы ты поступил, если б тебе нужно было запереть десять вольноперов? ... Запер бы двадцать, а десять бы выпустил..." (с)
Аноним: А если четные подряд: 1 2 4 7 9 9 6 6 6 6 5
Аноним: Стоп.... как это "четные подряд"? Рассматривается ряд натуральных чисел в интервале [a,b], а не элементы какого-то массива.
Аноним: В ИНТЕРВАЛЕ, но не в МАССИВЕ. Ну чем не интервал: a=4, следующее 5, далее 6, 6, 7, 9, 10, 10, 10, 10 и, наконец, b=11???

Ответы на вопрос

Ответил ЕнотЕнотыч
1
var a,b,i,sum: integer; 
begin 

write ('Введите границы интервала: ');

read (a,b); 

for i:= a to b do 

if i mod 2 = 0 then sum:=sum + i;

writeln ('Сумма четных чисел в интервале от А до Б = ',sum);

end.

Ответил Аноним
3



uses Crt;
 var a, b, temp, i, S:integer;
 begin
 ClrScr;

 Write (' a = ');   ReadLn(a);
 Write (' b = ');   ReadLn(b);
 S:=0;
 i:=a;
 while i<=b do
   begin
     if (i mod 2 = 0) then S:=S+i;
     i:=i+1;
   end;
 WriteLn(' S = ', S);
 ReadLn;
 end.

Новые вопросы