Помогите, пожалуйста, написать программу на языке С
Программа должна считывать последовательность 25 чисел из файла, заменить все элементы, которые меньше среднего арифметического этих элементов, на 0 и вывести новую последовательность в новый файл
Ответы на вопрос
Ответил petyaGavrikov
0
#include <stdio.h>
main()
{
int x, s=0, n=0;
float sr;
FILE *fin, *fout;
fin = fopen("input.txt", "r");
fout = fopen("output.txt", "w");
while (fscanf(fin, "%d", &x) == 1) {
s+=x;
n++;
}
sr = 1.0*s/n;
fclose (fin);
fin = fopen("input.txt", "r");
while (fscanf(fin, "%d", &x) == 1) {
if (x < sr) x = 0;
fprintf (fout, "%d ", x);
}
fclose (fout);
fclose (fin);
}
Пример:
Файл input.txt:
21 45 87 61 90 43 70 15 33 58
Файл output.txt:
0 0 87 61 90 0 70 0 0 58
main()
{
int x, s=0, n=0;
float sr;
FILE *fin, *fout;
fin = fopen("input.txt", "r");
fout = fopen("output.txt", "w");
while (fscanf(fin, "%d", &x) == 1) {
s+=x;
n++;
}
sr = 1.0*s/n;
fclose (fin);
fin = fopen("input.txt", "r");
while (fscanf(fin, "%d", &x) == 1) {
if (x < sr) x = 0;
fprintf (fout, "%d ", x);
}
fclose (fout);
fclose (fin);
}
Пример:
Файл input.txt:
21 45 87 61 90 43 70 15 33 58
Файл output.txt:
0 0 87 61 90 0 70 0 0 58
Ответил LegoLAS09
0
Огромное спасибо, очень выручили
Новые вопросы
Английский язык,
2 года назад
Английский язык,
2 года назад
Литература,
8 лет назад
Математика,
9 лет назад
Алгебра,
9 лет назад