Помогите, пожалуйста, написать программу на С++. Пользователь вводит число а. Нужно, чтобы программа определила положительно ли число, если да, то:
1) посчитать сколько разрядов в этом числе;
2) определить каких разрядов больше: со значением от 0 до 4 или от 5 до 9.
Ответы на вопрос
Ответил pz4t9v0d4tly
0
#include <iostream>
using namespace std;
int main() {
setlocale(LC_ALL, "Russian");
string a;
cin >> a;
if(stoi(a)>=0) {
cout << a.length() << " разрядов";
} else {
cout << "Wrong data";
// Прошу перефразировать вторую часть задания, исправлю. Какое значение?
}
}
Новые вопросы
Окружающий мир,
2 года назад
Алгебра,
2 года назад
Математика,
2 года назад
Психология,
8 лет назад
Алгебра,
8 лет назад