ПОМОГИТЕ ПОЖАЛУЙСТА НАПИСАТЬ ПРОГРАММУ НА "С"!!!
Напишите программу: введите длину и ширину прямоугольника и найдите окружность и площадь прямоугольника (требования: убедитесь, что длина и ширина, введенные пользователем, должны быть натуральными числами).
Ответы на вопрос
Ответ:
снепчат
Объяснение:
из приложений снепчат но а так сноупхром
Ответ:
Объяснение:
#include <iostream>
#include <conio.h>
#include <string.h>
#include <stdio.h>
int getValue(const char *title)
{
int value = 0;
while (true)
{
std::cout << title;
std::cin >> value;
if (value > 0)
break;
std::cout << "Incorrect input" << std::endl;
std::cin.clear();
std::cin.ignore(32767, '\n');
}
return value;
}
int main()
{
int length = getValue("Enter rect length: ");
int width = getValue("Enter rect width: ");
std::cout << std::endl << "length = " << length << ", width = " << width;
std::cout << std::endl << "P = " << (length + width) * 2 << ", S = " << length * width;
_getch(); //Экран не закрывается, пока не нажата любая клавиша
return 0;
}
