Помогите пожалуйста написать программу на Паскале по функции z=a2-b/a-1 ВЕТВЛЕНИЕМ!!!!!! если а=0, то решения нет, потому что на 0 делить нельзя и если a<>0
Ответы на вопрос
Ответил manamahkrit
0
Не понял с a2, если не квадрат, то позже исправлю
program func;
var
a, b: integer;
z: real;
begin
writeln('Введите a и b');
readln(a,b);
if a=0 then
writeln('Решения нет')
else if a<>0 then
begin
z:=((Sqr(a)-b)/(a-1));
writeln('z=',z);
end;
end.
program func;
var
a, b: integer;
z: real;
begin
writeln('Введите a и b');
readln(a,b);
if a=0 then
writeln('Решения нет')
else if a<>0 then
begin
z:=((Sqr(a)-b)/(a-1));
writeln('z=',z);
end;
end.
Новые вопросы