Информатика, вопрос задал svetlanka1387 , 8 лет назад

Помогите пожалуйста написать программу на Паскаль: Создать две матрицы m x n и n x m, заполнить первую случайными числами, вывести на экран. Транспонировать первую матрицу во вторую и тоже вывести на экран.

Ответы на вопрос

Ответил egor720
0
readln(x);
x := x div 100;
x := x mod 10;
x := x * x;
writeln(x);

вроде так. 
или вот так
var
  n:longint;
begin
  Write('Введите пятизначное натуральное число: ');
  Read(n);
  Writeln('Квадрат средней цифры равен ',
    sqr((n div 100) mod 10))
end.
текстовое решение
Введите пятизначное натуральное число: 15624
Квадрат средней цифры равен 36
Новые вопросы