Информатика, вопрос задал Илья8915 , 1 год назад

Помогите пожалуйста написать программу на C#
В данной действительной квадратной матрице порядка n найти сумму элементов строки, в которой расположен элемент с наименьшим значением. Предполагается, что такой элемент единствен.

Ответы на вопрос

Ответил Helper211
2

Ответ:

using System;

namespace ConsoleApp1

{

   class Program

   {

       static void Main(string[] args)

       {

           int n,i,j, imin = 0;

           double sum = 0;

           Console.Write("Введите n: ");

           n = Convert.ToInt32(Console.ReadLine());

           double[,] A = new double[n, n];

           Random r = new Random();

           for (i = 0; i < n; i++)

           {

               for (j = 0; j < n; j++)

               {

                   A[i, j] = r.NextDouble()*100 - 50;

                   Console.Write("{0,10:0.0}", A[i, j]);

                   if (A[i, j] < A[imin / 10, imin % 10]) imin = i * 10 + j;

               }

               Console.WriteLine();

           }

           i = imin / 10;

           for (j = 0; j < n; j++) sum += A[i, j];

           Console.WriteLine("Сумма элементов строки с наименьшим значением: {0,10:0.0}", sum);

       }

   }

}


Илья8915: Матрица должна заполняется случайными числами
Helper211: Ответ изменен.
Илья8915: вылетает
Helper211: Что пишет?
Илья8915: просто сама сразу закрывается без всего
Helper211: Добавьте в конец программы "Console.ReadKey();"
Илья8915: Спасибо работает
Новые вопросы