Помогите пожалуйста написать программу на C++.
Условие такого: Вычислить сумму ряда, 1-1/2+1/3-1/4...1/n.
По введенному n нужно посчитать сумму.
Ответы на вопрос
Ответил kavko903
0
#include <iostream>
using namespace std;
int main()
{
int n, i, m = 1;
double s = 0.0;
cin>>n;
for (i = 1; i <= n; s += double(m)/i, m = -m, i++);
cout<<s;
}
using namespace std;
int main()
{
int n, i, m = 1;
double s = 0.0;
cin>>n;
for (i = 1; i <= n; s += double(m)/i, m = -m, i++);
cout<<s;
}
Ответил maximpogodin20
0
большое спасибо)
Новые вопросы