Помогите пожалуйста написать надо на проге Pascal
напишите пропоследовательности грамму которая в натуральных чисел определяет максимальное число оканчивающееся на 8. Программа получает на вход количество чисел в последовательности, а затем сами числа. В последовательности имеется число, которое оканчивающееся на 8. Количество чисел не превышает 1000. введённые числа не превышают 30 000. Программа должна вывести ожно число-максимальное число, оканчивающееся на 8
Ответы на вопрос
Ответил Puz1koO
1
var
i,max,n:integer;
begin
max:=0;
readln(n);
for i:=1 to n do
begin
readln(n);
if (n>max) and (n mod 10 = 8) then
max:=n;
end;
writeln;
writeln(max);
end.
Новые вопросы
Русский язык,
2 года назад
Английский язык,
2 года назад
Биология,
2 года назад
Математика,
8 лет назад