Информатика, вопрос задал k26081999k , 1 год назад


ПОМОГИТЕ ПОЖАЛУЙСТА.
Надо написать программу в Python.

В базе данных хранятся данные о спортсменах. Пользователю необходимо заполнить базу данных.
Программа спрашивает «Ввести ещё одного участника?», и пока пользователь отвечает «Да/да», программа запрашивает ввод характеристик одного спортсмена с клавиатуры.
После ввода информации о всех спортсменах программа пишет «База данных заполнена».

Ответы на вопрос

Ответил sahbazovaaysel24
1

Ответ:

answer = input("Ввести ещё одного участника?")

while answer.lower() == "да":

   name = input("Введите имя")

   surname = input("Введите фамилию")

   sport = input("Введите вид спорта")

   trainer = input("Введите тренера")

   print("Фамилия Имя:", name ,surname, "Вид спорта:",sport, "Занимается у тренера:",trainer)

   answer = input("Ввести ещё одного участника?")

else:

   print("База данных заполнена")

Ответил Ivan19074
1

Ответ:

Объяснение:

import json

i = "да"

data = []

while (i == "да"):

    i = input("Ввести ещё одного участника?").lower()

    x = input("Введите данные спортсмена в формате JSON")

   data.append(json.load(x))

print("База данных заполнена")

Новые вопросы