Помогите пожалуйста:
Массивы:
1) Дан одномерный массив. Даны целые числа С1,...,C11. Имеются ли в последовательности С1,...,C11
два идущих подряд члена кратных 3 .
2) Дан одномерный массив. Найти номера всех
элементов с минимальным значением.
Программы составить нужно!
Ответы на вопрос
Ответил uropb123
0
2)
program min_index;
var mas:array[1..100] of integer;
n,i,min:integer;
begin
write('Введите кол-во элементов массива:');
readln(n);
writeln('Введите элементы массива:');
for i:=1 to n do read(mas[i]);
writeln('Номера минимальных элементов массива:');
min:=mas[1];
for i:=2 to n do
if mas[i]<min
then min:=mas[i];
for i:=1 to n do
if mas[i]=min then
write(i,' ');
readln;
end.
1) Первую честно сейчас не соображу, потому что мне сейчас напомнили что я должен написать программу на завтра ( зачет) на ассемблере...универ зло.. извини что без первой))
program min_index;
var mas:array[1..100] of integer;
n,i,min:integer;
begin
write('Введите кол-во элементов массива:');
readln(n);
writeln('Введите элементы массива:');
for i:=1 to n do read(mas[i]);
writeln('Номера минимальных элементов массива:');
min:=mas[1];
for i:=2 to n do
if mas[i]<min
then min:=mas[i];
for i:=1 to n do
if mas[i]=min then
write(i,' ');
readln;
end.
1) Первую честно сейчас не соображу, потому что мне сейчас напомнили что я должен написать программу на завтра ( зачет) на ассемблере...универ зло.. извини что без первой))
Новые вопросы
Английский язык,
2 года назад
История,
2 года назад
Математика,
10 лет назад
Математика,
10 лет назад
Алгебра,
10 лет назад