помогите пожалуйста исправить программу с++
Напишите программу, которая заменяет в символьной строке все буквы a на буквы b , буквы A на буквы B , буквы b на буквы a и буквы B на буквы A .
Входные данные
Входная строка содержит символы латинского алфавита, как строчные, так и заглавные.
Выходные данные
Программа должна вывести в первой строке получившуюся в результате обработки символьную строку, а во второй – количество выполненных замен.
Примеры
входные данные
aabbccAABBCC
выходные данные
bbaaccBBAACC
8
--------------------
#include < stdio.h >
#include < iostream >
#include < string >
using namespace std;
int main()
{
int i, d=0
string s;
cout << "Введите строку";
getline(cin,s);
for(int i=0;i
{
if(s[i]== 'A'){
s[i] = 'B';
d++;
}
else if(s[i]== 'a'){
s[i] = 'b';
d++;
}
else if(s[i]== 'B'){
s[i] = 'A';
d++;
}
else if(s[i]== 'b'){
s[i] = 'a';
d++;
}
}
cout< }
Ответы на вопрос
Ответил Hn94
1
Ответ:
Объяснение:
#include <iostream>
#include <string>
using namespace std;
int main()
{
setlocale(LC_ALL, "ru");
int d = 0;
string s = "";
cout << "Введите строку:" << endl;
getline(cin, s);
for (int i = 0; i < s.length(); i++)
{
if (s[i] == 'A')
{
s[i] = 'B';
d++;
}
else if (s[i] == 'a')
{
s[i] = 'b';
d++;
}
else if (s[i] == 'B')
{
s[i] = 'A';
d++;
}
else if (s[i] == 'b')
{
s[i] = 'a';
d++;
}
}
cout << s << endl
<< d << endl;
}
Новые вопросы
Русский язык,
2 года назад
Английский язык,
2 года назад
Физика,
2 года назад
Другие предметы,
2 года назад
Геометрия,
8 лет назад
#include
#include
using namespace std;
int main()
{
int i, d=0
string s;
cout << "Введите строку";
getline(cin,s);
for(int i=0;i
{
if(s[i]== 'A'){
s[i] = 'B';
d++;
}
else if(s[i]== 'a'){
s[i] = 'b';
d++;
}
else if(s[i]== 'B'){
s[i] = 'A';
d++;
}
else if(s[i]== 'b'){
s[i] = 'a';
d++;
}
}
cout< }