Помогите пожалуйста, информатика, надо написать программу), говорят легко, но я не разбираюсь
Приложения:

Ответы на вопрос
Ответил petyaGavrikov
0
Программа на паскале:
var x,y:real;
begin
write('x = ');
readln(x);
if x>=1
then y:=x*x+sin(x)
else if x>0 then y:=(1-x)/sqrt(sin(x)/cos(x))
else y:=x*x*x+8*x-1;
writeln('y = ',y);
end.
Пример:
x = 3.945
y = 14.8432991568405
var x,y:real;
begin
write('x = ');
readln(x);
if x>=1
then y:=x*x+sin(x)
else if x>0 then y:=(1-x)/sqrt(sin(x)/cos(x))
else y:=x*x*x+8*x-1;
writeln('y = ',y);
end.
Пример:
x = 3.945
y = 14.8432991568405
Ответил lnirikiri
0
а если там 0<x<1, то не надо писать (x>0) and (x<1)? просто x>0 правильно? да?)
Ответил petyaGavrikov
0
Можно и написать, но второе условие (x<1) будет лишним (так как условие x>=1 в этой части ложно).
Новые вопросы
Физика,
2 года назад
Математика,
2 года назад
Математика,
8 лет назад
Биология,
8 лет назад
Математика,
9 лет назад