Информатика, вопрос задал 120756410Samara , 6 лет назад

Помогите, пожалуйста, дописать программу в С++
Сколько чисел нужно взять в последовательности 1/2, 1/3, 1/4, ... чтобы получить число, больше чем n? n вводится с клавиатуры.

Приложения:

STGLN: тут не ДОписывать надо, а ПЕРЕписывать ибо то, что на скрине больно читать ))

Ответы на вопрос

Ответил STGLN
1

#include <iostream>

using namespace std;

void solve() {

   double n, cur = 0;

   int cnt = 0;

   cin >> n;

   while(cur <= n) {

       cur += 1.0 / (cnt + 2);

       cnt++;

   }

   cout << cnt;

}

int main(){

   solve();

}

Новые вопросы