ПОМОГИТЕ ПОЖАЛУЙСТА,ДАЮ 30 БАЛЛОВ!
Составьте программу ,которая формирует массив ,содержащий 12 случайных вещественных чисел ,принадлежащих промежутку от [-10;30] , и подсчитывает произведение всех отрицательных чисел. Вывод в столбец с тремя десятичными знаками.
Ответы на вопрос
Ответил Soqwa
0
var
a:array[1..12] of real;
i:integer;
pr:real;
begin
randomize;
pr:=1;for i:=1 to 12 do begin
a[i]:=random(41)*0.9-10;
if (a[i] < 0) then
pr:=pr*a[i];
end;
writeln(pr:5:3)
end.
a:array[1..12] of real;
i:integer;
pr:real;
begin
randomize;
pr:=1;for i:=1 to 12 do begin
a[i]:=random(41)*0.9-10;
if (a[i] < 0) then
pr:=pr*a[i];
end;
writeln(pr:5:3)
end.
Ответил Sky09
0
uses crt;
var a:array[1..12] of real;
x:integer;
p:real;
begin
randomize;
p:=1;
for x:=1 to 12 do
begin
a[x]:=random(41)*(random(10)/5)-10;
writeln('a[',x,']:',a[x]);
if a[x]<0 then p:=p*a[x];
end;
writeln;
writeln(p:6:3);
end.
var a:array[1..12] of real;
x:integer;
p:real;
begin
randomize;
p:=1;
for x:=1 to 12 do
begin
a[x]:=random(41)*(random(10)/5)-10;
writeln('a[',x,']:',a[x]);
if a[x]<0 then p:=p*a[x];
end;
writeln;
writeln(p:6:3);
end.
Новые вопросы
Другие предметы,
2 года назад
Французский язык,
2 года назад
Математика,
10 лет назад
Физика,
10 лет назад