ПОМОГИТЕ, ПОЖАЛУЙСТА, ДАЮ 100 БАЛЛОВ! PascalABC.net
Мальчик Петя строит из кубиков лестницу. Лестница представляет собой несколько строящихся рядом башенок из кубиков, каждая из которых ровно на один кубик выше предыдущей. Требуется по имеющемуся у мальчика Пети числу кубиков определить, какой в кубиках будет высота последней ступеньки.
Входные данные
Входной файл INPUT.TXT содержит число К – количество кубиков у мальчика Пети (1 ≤ K ≤ 106).
Выходные данные
В выходной файл OUTPUT.TXT выведите количество кубиков в последней ступеньке у максимально высокой лестницы, которую можно построить из K кубиков.
Ответы на вопрос
Ответил Zlkl13
1
Ответ:
program l;
var f:text;
s,K:integer;
begin
assign(f,'D:\INPUT.TXT');
reset(f);
read(f,s);
K:=s;
close(f);
s:=0;
repeat
s:=s+1;
K:=K-s
until K<=s;
assign(f,'D:\OUTPUT.TXT');
rewrite(f);
writeln(f,s);
close(f)
end.
Объяснение:
фото
Приложения:

Новые вопросы
Математика,
1 год назад
Физика,
1 год назад
История,
1 год назад
Алгебра,
1 год назад
Русский язык,
6 лет назад