Информатика, вопрос задал ishdhsieiwksbshs , 6 лет назад

ПОМОГИТЕ ПОЖАЛУЙСТА 8КЛАСС НА ПИТОНЕ
Напишите программу, которая получает с клавиатуры натуральное число и определяет,

сколько в его записи не четных цифр.​

Ответы на вопрос

Ответил dmitrijdenisov359
1

Ответ:

a = int(input('Число: '))

s = 0 # здесь будет кол-во четных цифр

for i in list(str(a)): # превратил введённое число в строку, и эту строку сделал списком.

   if int(i)%2: s += 1 # проверяю есть ли остаток от деления у i-го числа, и если нет - то оно четное, если да,  прибовляю 1 к s

print("Количество нечетных цифр в введённом числе =", s)

Новые вопросы