Информатика, вопрос задал Rosiie , 1 год назад

Помогите пожалуйста!!! 10 класс.
Python.
Дан массив, содержащий 8 положительных целых чисел, не превышающих 1000
Необходимо найти в этом массиве количество двузначных элементов, которые кратны числу 5,
и заменить каждый из таких элементов на это количество. Напишите программу для решения
этой задачи. В качестве результата программа должна вывести изменённый массив, по одному
элементу в строке.
Язык программирования Python.

Ответы на вопрос

Ответил iosyastalin1998
1

Ответ:

n = int(input())

#Сколько чисел

value = []

z = 0

for i in range(n):

   t = int(input())

   value.append(t)

   if t // 100 == 0 and t % 5 == 0:

       z += 1

for i in value:

   if i // 100 == 0 and i % 5 == 0:

       g = value.index(i)

       value.remove(i)

       value.insert(g, z)

for i in value:

   print(i)

Новые вопросы