Информатика, вопрос задал КсюшаБ1 , 8 лет назад

Помогите пожалуйста:

1)Составить программу, которая выводи на экран в первую строку все числа четные от 1 до 20 через пробел, а во вторую строчку все нечетные числа от 20 до 30 через запятую;
2)Составить программу, которая находит сумму нечетные чисел и произведение четных чисел от 1 до 10;
3) Написать программу, которая вычисляет количество двухзначных чисел кратных и 2, и 3
Заранее огромное спасибо

Ответы на вопрос

Ответил nelle987
0
Python 3.
1) print(*range(2, 21, 2))
print(*range(21, 31, 2), sep=',')

2) mysum = 0
for i in range(1, 11, 2):
    mysum += i
print(mysum)

prod = 1
for i in range(2, 11, 2):
    prod *= i
print(prod)

3) print(len([x for x in range(10, 100) if (x % 2 == 0) and (x % 3 == 0)]))

Новые вопросы