Информатика, вопрос задал nadiyaru , 8 лет назад

Помогите Пожалуйста.

1
Написать программу, которая находит в массиве значения, повторяющиеся два и более раз, и показывает их на экран.

2
Написать программу, которая находит в массиве самое маленькое нечетное число и показывает его на экран.

ДЛЯ ВСЕХ ЗАДАНИЙ:

Размер массива вводит пользователь.
Элементы массива рандомно в диапазоне [ 13;27 ].

Ответы на вопрос

Ответил Khaker1999
0
int main()

  int  
    numOfEl,          // number of elements in the array
    minNum = 28,  // minimal number in the array   
    *mainArray,      // main array   
    cntArray[15];    // array for counting the repeated numbers

    std::cout << "Input the number of the elements: "; 
    std::cin >> numOfEl;

    mainArray = new int[numOfEl];

    for (int i = 0; i < 15; i++)
      cntArray[i] = 0;   

    for (int i = 0; i < numOfEl; i++)
    {
      cntArray[(mainArray[i] = rand() % 15 + 13) - 13]++;

      if (mainArray[i] < minNum && mainArray[i] % 2 != 0)
        minNum = mainArray[i]; 
    }

#ifdef _DEBUG
    std::cout << "Array: ";
   
    for (int i = 0; i < numOfEl; i++)
      std::cout << mainArray[i] << ";" << std::endl;
#endif

    std::cout << "Repeated numbers: ";
    for (int i = 0; i < numOfEl; i++) 
      if (cntArray[i] >= 2)
        std::cout << i + 13 << "; ";

    std::cout << std::endl << "Minimal number: " << minNum << std::endl;

    system("pause");
   
   return 0;
} /* End of the 'main' function */
Ответил Khaker1999
0
Только тут случайные числа одни и те же будут. Добавь там 'srand(time(0));'
Ответил Khaker1999
0
И подключи <ctime>
Новые вопросы