Информатика, вопрос задал Anesjon , 9 лет назад

помогите пож . Составить программу, запрашивающую у пользователя дату в кратком формате дд.мм.гг (например: 15.10.2012), и отображающую эту дату в полном формате (например: 15 октября 2012 года).

Ответы на вопрос

Ответил Gleb1Kosyrev
0
//Pascal ABC.NET 3.1 сборка 1256

Var
 ars:array[1..12] of string:=('января','февраля','марта','апреля','мая','июня','июля','августа','сентября','октября','ноября','декабря');
 s:string;
begin
read(s);
if s[1]='0' then delete(s,1,1);
write(copy(s,1,pos('.',s)-1),' ');
delete(s,1,pos('.',s));
write(ars[strtoint(copy(s,1,pos('.',s)-1))],' ');
delete(s,1,pos('.',s));
write(s,' года');
end.

Пример ввода:
15.10.2012
Пример вывода:
15 октября 2012 года
Новые вопросы