Информатика, вопрос задал houussee30 , 7 лет назад

помогите, помогите
1. Написать программу по нахождению максимального элемента массива;
2. Написать программу по нахождению отрицательных, положительных и нулевых элементов массива

Ответы на вопрос

Ответил ПрофессорНиколаевич
0

Program maximal;

const

nmax=100;

var

a:array[1..nmax] of integer;

N,i,max:integer;

begin

readln(N);

max:=0;

for i:=1 to N do

 begin

   read(a[i]);

   if max<a[i] then

     max:=a[i];

end;

write(max);

end.


////////


2) Program B;

    const

nmax=100;

var

a:array[1..nmax] of integer;

N,i,z:integer;

begin

readln(N);

z:=0;

for i:=1 to N do

 begin

   read(a[i]);

   if a[i]>0 then

       write(a[i],' ');

    if a[i]=0 then

       z:=z+1;

end;

writeln();

for i:=1 to N do

   begin

      if a[i]<0 then

        write(a[i],' ');

  end;

writeln();

for i:=1 to z do

   write('0',' ')

end.


Ответил ПрофессорНиколаевич
0
Во 2-ом задании, в 1-ой строке будут положительные, во 2-ой отрицательные, в 3-ей нулевые.
Ответил houussee30
0
большое Вам спасибо
Новые вопросы