Помогите по информатике по Паскалю
3) Из элементов массива Р сформировать массив М той же размерности по правилу: если номер четный, то М[I]=I*P[I],если нечетный, то M[I]=-P[I].
5) Составить программу вычисления и печати значений функции Y=(sinx+1)√cos4x. Значения аргументов задать в массиве X, состоящего из 10 элементов. Значения функции записать в массив Y.
6) Заменить первые К элементов массива на противоположные по знаку.
Ответы на вопрос
Ответил AnonimusPro
0
Program n3;
const n=5;
var p,m: array[1..n] of integer;
i: integer;
begin
for i:=1 to n do begin
read(p[i]);
if i mod 2=0 then m[i]:=i*p[i] else m[i]:=(-1)*p[i];
end;
writeln;
for i:=1 to n do write(m[i],' ');
end.
Program n5;
const n=10;
var x,y: array[1..n] of real;
i: integer;
begin
for i:=1 to n do begin
read(x[i]);
y[i]:=(sin(x[i])+1)*sqrt(cos(4*x[i]));
end;
writeln;
for i:=1 to n do write(y[i],' ');
end.
Program n6;
const n=5;
var a: array[1..n] of integer;
i,k: integer;
begin
readln(k);
for i:=1 to n do read(a[i]);
writeln;
for i:=1 to k do a[i]:=(-1)*a[i];
for i:=1 to n do write(a[i],' ');
end.
Новые вопросы