Помогите по блок-схеме составить программу.
Приложения:

Ответы на вопрос
Ответил Aillianna
0
//PascalABC.Net 3.1.0.1200
var
a, b, c, d, x, y: real;
begin
readln(a, b, c, d);
if a * b >= c * d then
if a * b >= 0 then
x := sqrt(a * b)
else begin
writeln('Корня нет');
exit;
end
else x := c * Power(d, 1 / 3);
if x < 1 then
if a > 0 then
y := ln(a) + c * x
else begin
writeln('Логарифм не существует');
exit;
end
else
if a >= 3 then
y := c - a * x
else
y := b + d / x;
writeln(x, ' ', y);
end.
var
a, b, c, d, x, y: real;
begin
readln(a, b, c, d);
if a * b >= c * d then
if a * b >= 0 then
x := sqrt(a * b)
else begin
writeln('Корня нет');
exit;
end
else x := c * Power(d, 1 / 3);
if x < 1 then
if a > 0 then
y := ln(a) + c * x
else begin
writeln('Логарифм не существует');
exit;
end
else
if a >= 3 then
y := c - a * x
else
y := b + d / x;
writeln(x, ' ', y);
end.
Новые вопросы