Информатика, вопрос задал greeedy444 , 8 лет назад

ПОМОГИТЕ ПЛЗ! НА ЯЗЫКЕ ПАСКАЛЯ
Составьте программу, которая по введенному вами k – числу грибов, печатает фразу «Мы нашли в лесу k грибов, причем согласовывает окончание слова «гриб» с числом k.

Ответы на вопрос

Ответил Аноним
0
Var
k:integer;
Begin
Write('k = ');ReadLn(k);
Write('Мы нашли ',k);
if (k>9)and(k<20) then WriteLn(' грибов')
else
   Case k mod 10 of
   0,5..9:WriteLn(' грибов');
   1:WriteLn(' гриб');
   2..4:WriteLn(' гриба');
   End;
End.
Новые вопросы