Помогите плиз) информатика
Ввод 10 элементов массива случайным образом из диапазона от (-50,50). Посчитать кол-во отрицательных чисел. Написать программу
Ответы на вопрос
Ответил vladmor
0
var
a: array[1..10] of integer;
i, n: integer;
begin
for i := 1 to 10 do
begin
a[i] := random(101) - 50;
if a[i] < 0 then n := n + 1;
write(a[i]:4);
end;
writeln;
writeln('Количество отрицательных = ', n);
end.
Тестовое решение
30 1 -23 -36 15 -40 18 38 43 47
Количество отрицательных = 3
a: array[1..10] of integer;
i, n: integer;
begin
for i := 1 to 10 do
begin
a[i] := random(101) - 50;
if a[i] < 0 then n := n + 1;
write(a[i]:4);
end;
writeln;
writeln('Количество отрицательных = ', n);
end.
Тестовое решение
30 1 -23 -36 15 -40 18 38 43 47
Количество отрицательных = 3
Новые вопросы
Українська література,
2 года назад
Математика,
9 лет назад
Физика,
9 лет назад
Математика,
9 лет назад