Информатика, вопрос задал nastenca2001 , 9 лет назад

Помогите,плиииз:
дан массив из 20 элементов заполненный случайными целыми числами из интервала[-10;10].Выведите этот массив в строку и найдите наибольший элемент среди отрицательных элементов массива

Ответы на вопрос

Ответил simbion0
0
//PascalABC.NET
var
a: array [1..20] of integer;
i,n:integer;
begin
n:=-10;
for i:=1 to 20 do begin
A[i]:=(random(20)-10);
write(a[i],' ');
if (a[i] > n) and (a[i] < 0) then n:=a[i];
end;
writeln;
writeln('Наибольший элемент среди отрицательных: ',n);
end.
Новые вопросы