Информатика, вопрос задал Shkalnik3 , 9 лет назад

Помогите. Pascal abc
Написать программу, которая находит сумму целых чисел ,которые больше 100, меньшее 200, кратны 7 и заканчиваются на 1 или 4

Ответы на вопрос

Ответил bingo222
0
var sum, i : integer;
begin    
for i := 100 to 200 do  
    if (i mod 7 = 0) and ((i div 100 = 4) or (i div 100 = 1)) then          sum := sum + i;    writeln('Сумма равна ', sum)
end.
Ответил антагонист
0
далее, в if  скобку пропустил, вместо 10 в условии (div 10) напиши div 100
Ответил антагонист
0
var sum, i : integer; 
begin    
for i := 100 to 200 do   
    if (i mod 7 = 0) and ((i div 100 = 4) or (i div 100 = 1)) then          sum := sum + i;    writeln('Сумма равна ', sum) 
end.
Ответил антагонист
0
а так, классное решение, я вот затупил, через while пошол решать, муторно получилось и процессор грузит
Ответил антагонист
0
var a2,a,c,sym:
integer;
begin
for a:=100 to 200 do begin
  a2:=a;
  while (a2<>0) do begin
    c:=a2 mod 10;
    a2:=a2 div 10;
  end;
  if (a mod 7 = 0 ) and ((c=1) or (c=4)) then sym:=sym+a;
  end;
  writeln('сумма чисел от sym=',sym);
end.
Новые вопросы