ПОМОГИТЕ ОЧЕНЬ СРОЧНО. НАПИСАТЬ ПРОГРАММУ НА С++ ПОЖАААЛУУУЙСТА
напишите программу которая в последовательности целых чисел Вычисляет сумму всех чисел кратных 5 или 9. программа получает на вход целые числа количество введённых чисел неизвестно,последовательность чисел заканчивается числом 0 (0-признак окончания ввода, не входит в последовательность).
Количество чисел не превышает 20. Введённые числа по модулю не превышает 1500. Программа должна вывести одно число: сумму всех чисел, кратных 5 или 9.
Ответы на вопрос
Ответ:
#include <iostream>
#include <conio.h>
using namespace std;
int main()
{
setlocale(LC_ALL, "Russian");
const int SIZE = 20;
int Arr[SIZE] = {};
int Summa = 0;
cout << "Введите числа" << '\n';
for(int i = 0; i < SIZE; i++)
{
cin >> Arr[i];
if ((Arr[i] < 1500) && (Arr[i]>-1500)) //Проверяем числа в массиве больше,меньше 1500,-1500.
{
if (Arr[i]==0) // Проверяем встретиться ли нам 0.
{
break;//если встретился 0 то выходим из этого условия, а потом и из цикла.
}
if (Arr[i] % 5 == 0) // Проверяем числа на кратность 5. Если кратно то
{
Summa += Arr[i]; // Складываем все что кратно 5 в переменную Summa.
}
}
else //Этот else относиться к первому if где идет проверка больше,меньше 1500,-1500.
{
i--; // декремент не дает нам дальше заполнять массив покуда не введем число
// входящее в диапазон [-1500;1500].
cout << "Ваше число по модулю превышает 1500 " << endl; // оповещяем о том что введено неверное число
}
}
cout << "Сумма всех чисел, кратных 5 = " << Summa << endl;
_getch();// это просто чтобы окно не закрывалось, можно и в самом проекте это сделать.
return 0;
}
Объяснение: