Информатика, вопрос задал ivanova0lch1k , 2 года назад

Помогите очень прошу написать программу, которая по вводимому числу от 1 до 11 (номеру класса) выдаёт соответствующее сообщение «Привет, k-классник». Например, при k=1 - «Привет, первоклассник»


csharp: На каком языке?

Ответы на вопрос

Ответил Skynetus
0

Uses

crt;

var

a: integer

begin

writeln('введите класс');

readln(a);

case a of

1: writeln('привет, первоклассник');

2: writeln('привет, второклассник');

3: writeln('привет, третиклассник');

4: writeln('привет, четвероклассник');

5: writeln('привет, пятиклассник');

6: writeln('привет, шестиклассник');

7: writeln('привет, семиклассник');

8: writeln('привет, восьмиклассник');

9: writeln('привет, девятиклассник');

10: writeln('привет, десятиклассник');

11: writeln('привет, одиннадцатиклассник');

else writeln( 'введите другое значение');

end;

end.


Skynetus: Не обращай внимание на ошибки "третиклассника".
Skynetus: Если хочешь через переменную.

const
n: array [1..11] of String[11] = ('1', '2', '3', '4',
'5', '6', '7', '8', '9', '10', '11');
var
a: Integer;
begin
repeat
Write('Введите класс (от 1 до 11): '); ReadLn(a);
until a in [1..11];
WriteLn('Привет, ',n[a],'-классник');
end.
Новые вопросы