Информатика, вопрос задал aghornak , 9 лет назад

помогите очень нужно задача по паскалю
Вводятся семь целых чисел. Напишите программу, которая полсчитывает количество пятёрок среди введённых чисел

Ответы на вопрос

Ответил danabel2000
0
var c1,c2,c3,c4,c5,c6,c7,k:integer;
begin
read(c1,c2,c3,c4,c5,c6,c7);
if(c1=5)then k:=k+1;
if(c2=5)then k:=k+1;
if(c3=5)then k:=k+1;
if(c4=5)then k:=k+1;
if(c5=5)then k:=k+1;
if(c6=5)then k:=k+1;
if(c7=5)then k:=k+1;
writeln(k);
end.
Ответил aghornak
0
спасибо большое)))))))))))))
Ответил PopCop312
0
не по теме решение
Ответил aghornak
0
почему
Ответил PopCop312
0
var i, a, count: integer;
begin
count:=0;
for i:=1 to 7 do begin
  read(a);
  if(a=5) then count+=1;
  end;
writeln(count);
end.

если вы прошли циклы, то учитель дает задания именно на циклы
Ответил danabel2000
0
точно) не подумала о том что ввод тоже может в цикле быть)
Ответил aghornak
0
спасибо
Новые вопросы