Информатика, вопрос задал realanast1 , 9 лет назад

Помогите ~ Очень нужно


1. Составить программу нахождения площади ромба, если известны стороны и диагонали. (Паскаль. Если не трудно, то можно объяснить, как сделать программу)

2. 16x^4-√x (Паскаль)
16sqr(sqr(x))-(sqrt(x))

Ответы на вопрос

Ответил therealcf2014
0
1. Не знаю, как совместить стороны и диагонали в одном решении, сделал нахождение по диагоналям.

var d1, d2, S: real;
begin
write('Введите диагонали d1 и d2');
readln(d1, d2);
if(d1>0) and (d2>0) then
begin
S:=(d1*d2)/2;
writeln('Площадь равна: ', S)
end
else
writeln('Условия неверны!')
end.

Чтобы написать, достаточно знать основы паскаля. Если есть вопросы к какой-либо строке - напиши.

2. 
16*sqr(sqr(x))-(sqrt(x))
Новые вопросы