Помогите, нужно срочно...
Напишите программу, которая в последовательности натуральных чисел определяет сумму чисел, кратных 3 и оканчивающихся на 8. Программа получает на вход количество чисел в последовательности, а затем сами числа. В последовательности всегда имеется число, кратное 3 и оканчивающееся на 8.
Количество чисел не превышает 100. Введённые числа по модулю не превышают 300.
Программа должна вывести одно число: сумму чисел, кратных 3 и оканчивающихся на 8.
Ответы на вопрос
Ответил archery
0
var
i, s, n, d: integer;
begin
readln(n);
for i := 1 to n do
begin
readln(d);
if (d mod 10 = 8) and (d mod 3 = 0) then
s := s + d;
end;
writeln(s);
end.
i, s, n, d: integer;
begin
readln(n);
for i := 1 to n do
begin
readln(d);
if (d mod 10 = 8) and (d mod 3 = 0) then
s := s + d;
end;
writeln(s);
end.
Новые вопросы
Русский язык,
2 года назад
Алгебра,
2 года назад
Биология,
9 лет назад
Математика,
9 лет назад
Литература,
9 лет назад